Autor Thema: Kaputte Umlaute  (Gelesen 2980 mal)

Baroxam

  • Gast
Kaputte Umlaute
« am: Februar 20, 2012, 21:37:09 Nachmittag »
Im Ankündigungs-Subforum wird in einem Post von 2008 auf kaputte Umlaute hingewiesen. Ich meine mich zu erinnern, dass dies im Zusammenhang mit einem Wechsel der Forensoftware in Verbindung stand. Bei neu geposteten Beiträgen waren die Umlaute OK, nur die Umlaute von älteren Post hatten eben ein falsches Encoding (in der DB?).

Inzwischen sind aber so ziemlich alle Umlaute kaputt, auch von neuen Posts (2011). Wahrscheinlich wäre das kein Problem, wenn man wüsste, in welchem Zeichensatz die Sonderzeichen kodiert sind, das könnte man dann ja im Firefox einstellen. Müsste man zwar bei jeder Seite machen, aber besser als nix. Kann man irgendwie an die Info kommen?

Am schönsten wäre es natürlich, wenn man den Webserver zum Ausliefern der Seiten im korrekten Encoding bewegen könnte, aber das wäre ja sicher Arbeit auf Admin-Seite, das muss ja nicht unbedingt sein. Mit den kaputten Umlauten ist es nur leider sehr mühsam, die einzelnen Beiträge zu entziffern.

Oder bin ich hier der einzige, bei dem alle Umlaute kaputt sind? Die Seite wird als UTF-8 ausgeliefert (sagt Firefox), ich hab mal ein paar der gebräuchlicheren Encodings ausprobiert, leider ohne Erfolg...



Edit: ganz neue Einträge (wie dieser hier) scheinen nicht betroffen zu sein, das Problem ist also anscheinend gelöst. Ich hätte das Thema auch wieder gelöscht, darf aber nicht. Falls Dakur mag, kann er den Thread gern löschen; falls er das Encoding der "kaputten" Umlaute kennt, würde ich mich über eine kurze Info freuen. :)
« Letzte Änderung: Februar 20, 2012, 21:45:00 Nachmittag von Baroxam »

Offline Dakur Graustein

  • Zwergenhüter
  • Familienmitglied
  • ***
  • Beiträge: 2987
  • Zwergenheim-Orga Berater Forums-Admin
    • Das Portal
Re: Kaputte Umlaute
« Antwort #1 am: Februar 21, 2012, 17:14:46 Nachmittag »
Nö, ich antworte lieber darauf ;). Mittlerweile hat sich heraus gestellt, daß ich beide male es selbst verbockt hab weil ich bei der Wartung des Forums einen Fehler gemacht hab. Betroffen sind alle Beiträge mit umlauten die eben vor dem Wartumsdatum lagen. Aktuell sind wir (besonders Durgrim verdient hier Lob) damit beschäftgt einzelne Threads wieder zu reparieren. Einmal wieder reperiert bleiben sie so, leider hab ich aktuell zu wenig Zeit um die relevanten Threads alle wieder her zu stellen.
Bis denn
Dakur

Baroxam

  • Gast
Re: Kaputte Umlaute
« Antwort #2 am: Februar 22, 2012, 21:28:06 Nachmittag »
Vielen Dank für die Info. Dann besteht ja noch Hoffnung, dass eines Tages alle wichtigen Texte wieder lesbar werden. :)
Technische Details zum verwendeten Encoding der kaputten Umlaute lassen sich aber nicht mehr ermitteln, oder?

Offline Dakur Graustein

  • Zwergenhüter
  • Familienmitglied
  • ***
  • Beiträge: 2987
  • Zwergenheim-Orga Berater Forums-Admin
    • Das Portal
Re: Kaputte Umlaute
« Antwort #3 am: Februar 22, 2012, 21:46:41 Nachmittag »
Ich weiß nicht ob Dir das hilft, aber eine von diesen zwei Wartungsoptionen is wohl schuld:
"Konvertiere HTML-Entities zu UTF-8 Zeichen"
"Statistiken und Forumswerte neu berechnen"

Das kommt eben davon wenn ein Laie mit sowas rumhantiert. Bin halt lerning by doing gewöhnt und dann geht halt auch mal was kaputt wenn man lernt ;).
Bis denn
Dakur

Baroxam

  • Gast
Re: Kaputte Umlaute
« Antwort #4 am: Februar 23, 2012, 21:37:30 Nachmittag »
Nein, das hilft mir leider nicht. UTF-8 sind die Umlaute definitiv nicht. :D

Aber vielen Dank für's Nachschauen. :)

Gunda Feuerbart

  • Gast
Re: Kaputte Umlaute
« Antwort #5 am: März 19, 2012, 01:59:20 Vormittag »
Hey cool sie gehen wieder!!!
üöäüöäüöäüöäüöäüöäü  :anstossen: :anstossen: :anstossen:

Offline Dakur Graustein

  • Zwergenhüter
  • Familienmitglied
  • ***
  • Beiträge: 2987
  • Zwergenheim-Orga Berater Forums-Admin
    • Das Portal
Re: Kaputte Umlaute
« Antwort #6 am: März 19, 2012, 02:00:47 Vormittag »
Du die gehen die ganze Zeit, nur in alten Threads wurden sie durch einen Anwenderfehler des Admin umgewandelt.
Bis denn
Dakur

Gunda Feuerbart

  • Gast
Re: Kaputte Umlaute
« Antwort #7 am: März 21, 2012, 22:19:31 Nachmittag »
Achso O.O ....
hmmm ...
üöäüöäüöäüöpöäüöäüö  XDDDDDDDDDD
*feier*

dracken

  • Gast
Re: Kaputte Umlaute
« Antwort #8 am: November 15, 2012, 07:25:22 Vormittag »
Also ich pusch hier mal :)
Ich habe als ich auf das Forum gestoßen bin das ja auch gesehen und habe recherchiert und fand dies: http://forum.mysqldumper.de/dsb-s-umlaut-korrektur-duk-t2406.html

Vielleicht kann das ja helfen?

Ich hoffe es für alle Forennutzer.